CVE-2021-31804

NameCVE-2021-31804
DescriptionLeoCAD before 21.03 sometimes allows a use-after-free during the opening of a new document.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
leocad (PTS)stretch0.83.1-1vulnerable
buster18.02-1vulnerable
bullseye, sid19.07.1-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
leocadsource(unstable)(unfixed)unimportant

Notes

https://github.com/leozide/leocad/issues/645
https://github.com/leozide/leocad/commit/233affe3fcdc851fa82cb058871bddd0046e1c87
Crash in CLI tool, no security impact

Search for package or bug name: Reporting problems