CVE-2021-31863

NameCVE-2021-31863
DescriptionInsufficient input validation in the Git repository integration of Redmine before 4.0.9, 4.1.x before 4.1.3, and 4.2.x before 4.2.1 allows Redmine users to read arbitrary local files accessible by the application server process.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2658-1
NVD severitymedium
Debian Bugs990792

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
redmine (PTS)stretch3.3.1-4+deb9u3vulnerable
stretch (security)3.3.1-4+deb9u5fixed
sid4.0.7-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
redminesourcestretch3.3.1-4+deb9u4DLA-2658-1
redminesource(unstable)(unfixed)990792

Notes

https://www.redmine.org/news/131
https://www.redmine.org/projects/redmine/repository/revisions/20962

Search for package or bug name: Reporting problems