CVE-2021-31879

NameCVE-2021-31879
DescriptionGNU Wget through 1.21.1 does not omit the Authorization header upon a redirect to a different origin, a related issue to CVE-2018-1000007.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs988209

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wget (PTS)stretch (security), stretch1.18-5+deb9u3vulnerable
buster1.20.1-1.1vulnerable
bullseye1.21-1vulnerable
bookworm, sid1.21.2-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wgetsource(unstable)(unfixed)988209

Notes

[bullseye] - wget <no-dsa> (Minor issue)
[buster] - wget <no-dsa> (Minor issue)
[stretch] - wget <postponed> (Minor issue; can be fixed in next update)
https://mail.gnu.org/archive/html/bug-wget/2021-02/msg00002.html

Search for package or bug name: Reporting problems