CVE-2021-32055

NameCVE-2021-32055
DescriptionMutt 1.11.0 through 2.0.x before 2.0.7 (and NeoMutt 2019-10-25 through 2021-05-04) has a $imap_qresync issue in which imap/util.c has an out-of-bounds read in situations where an IMAP sequence set ends with a comma. NOTE: the $imap_qresync setting for QRESYNC is not enabled by default.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs988106, 988107

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mutt (PTS)buster1.10.1-2.1+deb10u6fixed
buster (security)1.10.1-2.1+deb10u5fixed
bullseye2.0.5-4.1+deb11u1fixed
bookworm, sid2.2.9-1fixed
neomutt (PTS)buster20180716+dfsg.1-1+deb10u2fixed
buster (security)20180716+dfsg.1-1+deb10u1fixed
bullseye20201127+dfsg.1-1.2fixed
bookworm20220429+dfsg1-4fixed
sid20220429+dfsg1-4.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
muttsourcestretch(not affected)
muttsourcebuster(not affected)
muttsource(unstable)2.0.5-4.1988106
neomuttsourcebuster(not affected)
neomuttsource(unstable)20201127+dfsg.1-1.2988107

Notes

[buster] - mutt <not-affected> (Vulnerable code introduced later)
[stretch] - mutt <not-affected> (Vulnerable code introduced later)
[buster] - neomutt <not-affected> (Vulnerable code introduced later)
https://gitlab.com/muttmua/mutt/-/commit/7c4779ac24d2fb68a2a47b58c7904118f40965d5
https://github.com/neomutt/neomutt/commit/fa1db5785e5cfd9d3cd27b7571b9fe268d2ec2dc
imap_qresync not enabled by default and considered an experimental feature

Search for package or bug name: Reporting problems