CVE-2021-3246

NameCVE-2021-3246
DescriptionA heap buffer overflow vulnerability in msadpcm_decode_block of libsndfile 1.0.30 allows attackers to execute arbitrary code via a crafted WAV file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2722-1, DSA-4947-1
NVD severitymedium
Debian Bugs991496

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libsndfile (PTS)stretch1.0.27-3vulnerable
stretch (security)1.0.27-3+deb9u2fixed
buster, buster (security)1.0.28-6+deb10u1fixed
bookworm, sid, bullseye1.0.31-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libsndfilesourcestretch1.0.27-3+deb9u2DLA-2722-1
libsndfilesourcebuster1.0.28-6+deb10u1DSA-4947-1
libsndfilesource(unstable)1.0.31-2991496

Notes

https://github.com/libsndfile/libsndfile/issues/687
https://github.com/libsndfile/libsndfile/commit/deb669ee8be55a94565f6f8a6b60890c2e7c6f32

Search for package or bug name: Reporting problems