CVE-2021-32491

NameCVE-2021-32491
DescriptionA flaw was found in djvulibre-3.5.28 and earlier. An integer overflow in function render() in tools/ddjvu via crafted djvu file may lead to application crash and other consequences.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2667-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
djvulibre (PTS)stretch3.5.27.1-7vulnerable
stretch (security)3.5.27.1-7+deb9u2fixed
buster3.5.27.1-10vulnerable
bookworm, bullseye, sid3.5.28-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
djvulibresourcestretch3.5.27.1-7+deb9u1DLA-2667-1
djvulibresource(unstable)3.5.28-2

Notes

https://bugzilla.redhat.com/show_bug.cgi?id=1943409
https://sourceforge.net/p/djvu/djvulibre-git/ci/cd8b5c97b27a5c1dc83046498b6ca49ad20aa9b6/ (chunk #5 / Patch9)

Search for package or bug name: Reporting problems