CVE-2021-32808

NameCVE-2021-32808
Descriptionckeditor is an open source WYSIWYG HTML editor with rich content support. A vulnerability has been discovered in the clipboard Widget plugin if used alongside the undo feature. The vulnerability allows a user to abuse undo functionality using malformed widget HTML, which could result in executing JavaScript code. It affects all users using the CKEditor 4 plugins listed above at version >= 4.13.0. The problem has been recognized and patched. The fix will be available in version 4.16.2.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs992292

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ckeditor (PTS)buster4.11.1+dfsg-1fixed
bullseye4.16.0+dfsg-2vulnerable
bookworm, sid4.19.1+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ckeditorsourcestretch(not affected)
ckeditorsourcebuster(not affected)
ckeditorsource(unstable)4.16.2+dfsg-1992292

Notes

[bullseye] - ckeditor <no-dsa> (Minor issue)
[buster] - ckeditor <not-affected> (Vulnerable code introduced later)
[stretch] - ckeditor <not-affected> (Vulnerable code introduced later)
https://github.com/ckeditor/ckeditor4/security/advisories/GHSA-6226-h7ff-ch6c
https://github.com/ckeditor/ckeditor4/commit/0cb59313c834c94cec4c4d4c114b6ecb0270e21a (v4.16.2)
Introduced by https://github.com/ckeditor/ckeditor4/commit/72428a762271d5e54a609a7913356a6d309c895d (v4.13.0)

Search for package or bug name: Reporting problems