CVE-2021-33038

NameCVE-2021-33038
DescriptionAn issue was discovered in management/commands/hyperkitty_import.py in HyperKitty through 1.3.4. When importing a private mailing list's archives, these archives are publicly visible for the duration of the import. For example, sensitive information might be available on the web for an hour during a large migration from Mailman 2 to Mailman 3.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-4922-1
NVD severitymedium
Debian Bugs989183

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
hyperkitty (PTS)buster, buster (security)1.2.2-1+deb10u1fixed
bullseye, sid1.3.4-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
hyperkittysourcebuster1.2.2-1+deb10u1DSA-4922-1
hyperkittysource(unstable)1.3.4-4989183

Notes

https://gitlab.com/mailman/hyperkitty/-/commit/9025324597d60b2dff740e49b70b15589d6804fa
https://gitlab.com/mailman/hyperkitty/-/issues/380
https://techblog.wikimedia.org/2021/06/11/discovering-and-fixing-cve-2021-33038-in-mailman3/

Search for package or bug name: Reporting problems