CVE-2021-3345

NameCVE-2021-3345
Description_gcry_md_block_write in cipher/hash-common.c in Libgcrypt version 1.9.0 has a heap-based buffer overflow when the digest final function sets a large count value. It is recommended to upgrade to 1.9.1 or later.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh
Debian Bugs981370

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libgcrypt20 (PTS)stretch (security), stretch1.7.6-2+deb9u3fixed
buster1.8.4-5fixed
bullseye, sid1.8.7-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libgcrypt20sourceexperimental1.9.1-1981370
libgcrypt20source(unstable)(not affected)

Notes

- libgcrypt20 <not-affected> (Only affected 1.9)
https://lists.gnupg.org/pipermail/gnupg-announce/2021q1/000456.html
https://dev.gnupg.org/T5275
Introduced by: https://git.gnupg.org/cgi-bin/gitweb.cgi?p=libgcrypt.git;a=commit;h=e76617cbab018dd8f41fd6b4ec6740b5303f7e13
Fixed by: https://git.gnupg.org/cgi-bin/gitweb.cgi?p=libgcrypt.git;a=commit;h=512c0c75276949f13b6373b5c04f7065af750b08

Search for package or bug name: Reporting problems