CVE-2021-33560

NameCVE-2021-33560
DescriptionLibgcrypt before 1.8.8 and 1.9.x before 1.9.3 mishandles ElGamal encryption because it lacks exponent blinding to address a side-channel attack against mpi_powm, and the window size is not chosen appropriately. (There is also an interoperability problem because the selection of the k integer value does not properly consider the differences between basic ElGamal encryption and generalized ElGamal encryption.) This, for example, affects use of ElGamal in OpenPGP.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libgcrypt20 (PTS)stretch (security), stretch1.7.6-2+deb9u3vulnerable
buster1.8.4-5vulnerable
bullseye1.8.7-3vulnerable
sid1.8.7-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libgcrypt20source(unstable)1.8.7-6

Notes

[buster] - libgcrypt20 <no-dsa> (Minor issue)
[stretch] - libgcrypt20 <no-dsa> (Minor issue)
https://dev.gnupg.org/T5328 (not yet public)
https://git.gnupg.org/cgi-bin/gitweb.cgi?p=libgcrypt.git;a=commit;h=3462280f2e23e16adf3ed5176e0f2413d8861320

Search for package or bug name: Reporting problems