DescriptionLibgcrypt before 1.8.8 and 1.9.x before 1.9.3 mishandles ElGamal encryption because it lacks exponent blinding to address a side-channel attack against mpi_powm, and the window size is not chosen appropriately. This, for example, affects use of ElGamal in OpenPGP.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libgcrypt20 (PTS)buster1.8.4-5+deb10u1vulnerable
bookworm, sid1.10.1-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs


[bullseye] - libgcrypt20 <no-dsa> (Minor issue)
[buster] - libgcrypt20 <no-dsa> (Minor issue)
[stretch] - libgcrypt20 <no-dsa> (Minor issue);a=commit;h=e8b7f10be275bcedb5fc05ed4837a89bfd605c61 (1.9.x)
Related to CVE-2021-33560, but not a duplicate. Unfortunately scope of CVE-2021-33560 and
CVE-2021-40528 got switched at some point, and CVE-2021-33560 referring to the blinding
hardening. We keep the original association as per 2021-09-19 (until MITRE clarifies on
a query).

Search for package or bug name: Reporting problems