DescriptionThe patch for CVE-2020-17380/CVE-2020-25085 was found to be ineffective, thus making QEMU vulnerable to the out-of-bounds read/write access issues previously found in the SDHCI controller emulation code. This flaw allows a malicious privileged guest to crash the QEMU process on the host, resulting in a denial of service or potential code execution. QEMU up to (including) 5.2.0 is affected by this.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs986795

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qemu (PTS)buster1:3.1+dfsg-8+deb10u8fixed
buster (security)1:3.1+dfsg-8+deb10u9fixed
bullseye (security), bullseye1:5.2+dfsg-11+deb11u2fixed
bookworm, sid1:7.1+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qemusourcebuster(not affected)


[buster] - qemu <not-affected> (CVE-2020-17380 wasn't backported to Buster)
New patch series:;a=commit;h=b263d8f928001b5cfa2a993ea43b7a5b3a1811e8;a=commit;h=8be45cc947832b3c02144c9d52921f499f2d77fe;a=commit;h=bc6f28995ff88f5d82c38afcfd65406f0ae375aa;a=commit;h=5cd7aa3451b76bb19c0f6adc2b931f091e5d7fcd;a=commit;h=cffb446e8fd19a14e1634c7a3a8b07be3f01d5c9
This is a re-submission of CVE-2020-17380 following its confusion with CVE-2020-25085 at a point, see RH bug

Search for package or bug name: Reporting problems