CVE-2021-3410

NameCVE-2021-3410
DescriptionA flaw was found in libcaca v0.99.beta19. A buffer overflow issue in caca_resize function in libcaca/caca/canvas.c may lead to local execution of arbitrary code in the user context.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2584-1
NVD severitymedium
Debian Bugs983686

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libcaca (PTS)stretch0.99.beta19-2.1~deb9u1vulnerable
stretch (security)0.99.beta19-2.1~deb9u2fixed
buster0.99.beta19-2.1vulnerable
bullseye, sid0.99.beta19-2.2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libcacasourcestretch0.99.beta19-2.1~deb9u2DLA-2584-1
libcacasource(unstable)0.99.beta19-2.2983686

Notes

[buster] - libcaca <no-dsa> (Minor issue)
https://github.com/cacalabs/libcaca/issues/52
https://bugzilla.redhat.com/show_bug.cgi?id=1928437
https://github.com/cacalabs/libcaca/commit/46b4ea7cea72d6b3ffe65d33e604b1774dcc2bbd
https://github.com/cacalabs/libcaca/commit/e4968ba6e93e9fd35429eb16895c785c51072015

Search for package or bug name: Reporting problems