CVE-2021-34146

NameCVE-2021-34146
DescriptionThe Bluetooth Classic implementation in the Cypress CYW920735Q60EVB does not properly handle the reception of continuous unsolicited LMP responses, allowing attackers in radio range to trigger a denial of service and restart (crash) of the device by flooding it with LMP_AU_Rand packets after the paging procedure.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs1024356

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
bluez-firmware (PTS)buster/non-free, bullseye/non-free1.2-4vulnerable
bookworm/non-free, sid/non-free1.2-7vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
bluez-firmwaresource(unstable)(unfixed)1024356

Notes

[bullseye] - bluez-firmware <no-dsa> (Non-free not supported)
[buster] - bluez-firmware <no-dsa> (Non-free not supported)
https://github.com/RPi-Distro/bluez-firmware/commit/31ad68831357d2019624004f1f0846475671088f

Search for package or bug name: Reporting problems