CVE-2021-34193

NameCVE-2021-34193
DescriptionStack overflow vulnerability in OpenSC smart card middleware before 0.23 via crafted responses to APDUs.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
opensc (PTS)bullseye0.21.0-1vulnerable
bookworm0.23.0-0.3+deb12u1fixed
sid, trixie0.25.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openscsource(unstable)0.22.0-1

Notes

[bullseye] - opensc <no-dsa> (Minor issue)
[buster] - opensc <no-dsa> (Minor issue)
https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=28185
https://github.com/OpenSC/OpenSC/commit/f015746d22d249642c19674298a18ad824db0ed7 (0.22.0-rc1)
https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=28843
https://github.com/OpenSC/OpenSC/commit/1db88374bb7706a115d5c3617c6f16115c33bf27 (0.22.0-rc1)
https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=28383
https://github.com/OpenSC/OpenSC/commit/5df913b7f57ad89b9832555d24c08d23a534311e (0.22.0-rc1)
https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=27719
https://github.com/OpenSC/OpenSC/commit/78cdab949f098ad7e593d853229fccf57d749d0c (0.22.0-rc1)
https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=28768
https://github.com/OpenSC/OpenSC/commit/d353a46d0444bb34ca28a3dcc884afe196f851b6 (0.22.0-rc1)
https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=28855
https://github.com/OpenSC/OpenSC/commit/7114fb71b54ddfe06ce5dfdab013f4c38f129d14 (0.22.0-rc1)
https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=29912
https://github.com/OpenSC/OpenSC/commit/1252aca9f10771ef5ba8405e73cf2da50827958f (0.22.0-rc1)
https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=30112
https://github.com/OpenSC/OpenSC/commit/17d8980cde7be597afc366b7e311d0d7cadcb1f4 (0.22.0-rc1)
https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=30800
https://github.com/OpenSC/OpenSC/commit/ae1cf0be90396fb6c0be95829bf0d3eecbd2fd1c (0.22.0-rc1)
https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=31448
https://github.com/OpenSC/OpenSC/commit/40c50a3a4219308aae90f6efd7b10213794a8d86 (0.22.0-rc1)
https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=31540
https://github.com/OpenSC/OpenSC/commit/40c50a3a4219308aae90f6efd7b10213794a8d86 (0.22.0-rc1)
https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=32149
https://github.com/OpenSC/OpenSC/commit/05648b0604bf3e498e8d42dff3c6e7c56a5bf749 (0.22.0-rc1)
https://github.com/OpenSC/OpenSC/commit/715c17c469f6c463dd511a5deb229da4de9ee100 (0.22.0-rc1)
https://github.com/OpenSC/OpenSC/issues/2841
CVE-2021-34193 is containing fixes as well for CVE-2021-42778, CVE-2021-42779, CVE-2021-42780,
CVE-2021-42781 and CVE-2021-42782 and might get rejected.

Search for package or bug name: Reporting problems