CVE-2021-34429

NameCVE-2021-34429
DescriptionFor Eclipse Jetty versions 9.4.37-9.4.42, 10.0.1-10.0.5 & 11.0.1-11.0.5, URIs can be crafted using some encoded characters to access the content of the WEB-INF directory and/or bypass some security constraints. This is a variation of the vulnerability reported in CVE-2021-28164/GHSA-v7ff-8wcx-gmc5.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs991188

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
jetty9 (PTS)stretch9.2.21-1+deb9u1fixed
stretch (security)9.2.30-0+deb9u2fixed
buster, buster (security)9.4.16-0+deb10u1fixed
bookworm, sid, bullseye9.4.39-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
jetty9sourcestretch(not affected)
jetty9sourcebuster(not affected)
jetty9source(unstable)9.4.39-3991188

Notes

[buster] - jetty9 <not-affected> (Vulnerable code was introduced in version 9.4.37)
[stretch] - jetty9 <not-affected> (Vulnerable code was introduced in version 9.4.37)
https://github.com/eclipse/jetty.project/security/advisories/GHSA-vjv5-gp2w-65vm
Fixed by https://github.com/eclipse/jetty.project/pull/6477

Search for package or bug name: Reporting problems