CVE-2021-34431

NameCVE-2021-34431
DescriptionIn Eclipse Mosquitto version 1.6 to 2.0.10, if an authenticated client that had connected with MQTT v5 sent a crafted CONNECT message to the broker a memory leak would occur, which could be used to provide a DoS attack against the broker.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mosquitto (PTS)stretch1.4.10-3+deb9u4fixed
stretch (security)1.4.10-3+deb9u5fixed
buster, buster (security)1.5.7-1+deb10u1fixed
bookworm, sid, bullseye2.0.11-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mosquittosourcestretch(not affected)
mosquittosourcebuster(not affected)
mosquittosource(unstable)2.0.11-1

Notes

[buster] - mosquitto <not-affected> (Vulnerable code introduced later)
[stretch] - mosquitto <not-affected> (Vulnerable code introduced later)
https://mosquitto.org/blog/2021/06/version-2-0-11-released/
https://bugs.eclipse.org/bugs/show_bug.cgi?id=573191

Search for package or bug name: Reporting problems