CVE-2021-3450

NameCVE-2021-3450
DescriptionThe X509_V_FLAG_X509_STRICT flag enables additional security checks of the certificates present in a certificate chain. It is not set by default. Starting from OpenSSL version 1.1.1h a check to disallow certificates in the chain that have explicitly encoded elliptic curve parameters was added as an additional strict check. An error in the implementation of this check meant that the result of a previous check to confirm that certificates in the chain are valid CA certificates was overwritten. This effectively bypasses the check that non-CA certificates must not be able to issue other certificates. If a "purpose" has been configured then there is a subsequent opportunity for checks that the certificate is a valid CA. All of the named "purpose" values implemented in libcrypto perform this check. Therefore, where a purpose is set the certificate chain will still be rejected even when the strict flag has been used. A purpose is set by default in libssl client and server certificate verification routines, but it can be overridden or removed by an application. In order to be affected, an application must explicitly set the X509_V_FLAG_X509_STRICT verification flag and either not set a purpose for the certificate verification or, in the case of TLS client or server applications, override the default purpose. OpenSSL versions 1.1.1h and newer are affected by this issue. Users of these versions should upgrade to OpenSSL 1.1.1k. OpenSSL 1.0.2 is not impacted by this issue. Fixed in OpenSSL 1.1.1k (Affected 1.1.1h-1.1.1j).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openssl (PTS)stretch1.1.0l-1~deb9u1fixed
stretch (security)1.1.0l-1~deb9u3fixed
buster1.1.1d-0+deb10u6fixed
buster (security)1.1.1d-0+deb10u7fixed
bullseye1.1.1k-1fixed
bullseye (security)1.1.1k-1+deb11u1fixed
bookworm, sid1.1.1l-1fixed
openssl1.0 (PTS)stretch1.0.2u-1~deb9u1fixed
stretch (security)1.0.2u-1~deb9u5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
opensslsourcestretch(not affected)
opensslsourcebuster(not affected)
opensslsource(unstable)1.1.1k-1
openssl1.0source(unstable)(not affected)

Notes

[buster] - openssl <not-affected> (Vulnerable code introduced in 1.1.1h)
[stretch] - openssl <not-affected> (Vulnerable code introduced in 1.1.1h)
- openssl1.0 <not-affected> (Vulnerable code introduced in 1.1.1h)
https://www.openssl.org/news/secadv/20210325.txt
https://git.openssl.org/gitweb/?p=openssl.git;a=commit;h=2a40b7bc7b94dd7de897a74571e7024f0cf0d63b

Search for package or bug name: Reporting problems