CVE-2021-3466

NameCVE-2021-3466
DescriptionA flaw was found in libmicrohttpd in versions before 0.9.71. A missing bounds check in the post_process_urlencoded function leads to a buffer overflow, allowing a remote attacker to write arbitrary data in an application that uses libmicrohttpd. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libmicrohttpd (PTS)stretch0.9.51-1fixed
buster0.9.62-1fixed
bullseye0.9.72-2fixed
bookworm, sid0.9.73-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libmicrohttpdsourcestretch(not affected)
libmicrohttpdsourcebuster(not affected)
libmicrohttpdsource(unstable)0.9.71-1

Notes

[buster] - libmicrohttpd <not-affected> (Vulnerable code introduced later)
[stretch] - libmicrohttpd <not-affected> (Vulnerable code introduced later)
Patch: https://git.gnunet.org/libmicrohttpd.git/commit/?id=a110ae6276660bee3caab30e9ff3f12f85cf3241
Introduced in https://git.gnunet.org/libmicrohttpd.git/commit/?id=55f715e15e3ce66babc939b5a670bee02d4d9571

Search for package or bug name: Reporting problems