CVE-2021-3468

NameCVE-2021-3468
DescriptionA flaw was found in avahi in versions 0.6 up to 0.8. The event used to signal the termination of the client connection on the avahi Unix socket is not correctly handled in the client_work function, allowing a local attacker to trigger an infinite loop. The highest threat from this vulnerability is to the availability of the avahi service, which becomes unresponsive after this flaw is triggered.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-3047-1
Debian Bugs984938

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
avahi (PTS)buster0.7-4+deb10u1vulnerable
bullseye0.8-5+deb11u1vulnerable
bookworm, sid0.8-6vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
avahisourcestretch0.6.32-2+deb9u1DLA-3047-1
avahisource(unstable)(unfixed)984938

Notes

[bullseye] - avahi <no-dsa> (Minor issue)
[buster] - avahi <no-dsa> (Minor issue)
https://github.com/lathiat/avahi/pull/330
https://bugzilla.redhat.com/show_bug.cgi?id=1939614#c3

Search for package or bug name: Reporting problems