CVE-2021-3479

NameCVE-2021-3479
DescriptionThere's a flaw in OpenEXR's Scanline API functionality in versions before 3.0.0-beta. An attacker who is able to submit a crafted file to be processed by OpenEXR could trigger excessive consumption of memory, resulting in an impact to system availability.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2701-1
NVD severitymedium
Debian Bugs986796

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openexr (PTS)stretch2.2.0-11vulnerable
stretch (security)2.2.0-11+deb9u4fixed
buster, buster (security)2.2.1-4.1+deb10u1vulnerable
bullseye2.5.4-2fixed
bookworm, sid2.5.7-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openexrsourcestretch2.2.0-11+deb9u3DLA-2701-1
openexrsource(unstable)2.5.4-1986796

Notes

[buster] - openexr <no-dsa> (Minor issue)
https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=25370
https://github.com/AcademySoftwareFoundation/openexr/commit/d80f11f4f55100d007ae80a162bf257ec291612c
https://github.com/AcademySoftwareFoundation/openexr/pull/830

Search for package or bug name: Reporting problems