CVE-2021-34825

NameCVE-2021-34825
DescriptionQuassel through 0.13.1, when --require-ssl is enabled, launches without SSL or TLS support if a usable X.509 certificate is not found on the local system.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs990567

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
quassel (PTS)stretch (security), stretch1:0.12.4-2+deb9u1vulnerable
buster1:0.13.1-1+deb10u2vulnerable
bookworm, sid, bullseye1:0.13.1-5vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
quasselsource(unstable)(unfixed)990567

Notes

[bullseye] - quassel <no-dsa> (Minor issue)
[buster] - quassel <no-dsa> (Minor issue)
[stretch] - quassel <no-dsa> (Minor issue)
https://github.com/quassel/quassel/pull/581
https://bugs.quassel-irc.org/issues/1728
'--require-ssl' flag added in https://github.com/quassel/quassel/pull/43

Search for package or bug name: Reporting problems