CVE-2021-3504

NameCVE-2021-3504
DescriptionA flaw was found in the hivex library in versions before 1.3.20. It is caused due to a lack of bounds check within the hivex_open function. An attacker could input a specially crafted Windows Registry (hive) file which would cause hivex to read memory beyond its normal bounds or cause the program to crash. The highest threat from this vulnerability is to system availability.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2656-1, DSA-4913-1
Debian Bugs988024

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
hivex (PTS)stretch1.3.13-2vulnerable
stretch (security)1.3.13-2+deb9u1fixed
buster1.3.18-1vulnerable
buster (security)1.3.18-1+deb10u1fixed
bullseye, sid1.3.20-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
hivexsourcestretch1.3.13-2+deb9u1DLA-2656-1
hivexsourcebuster1.3.18-1+deb10u1DSA-4913-1
hivexsource(unstable)1.3.20-1988024

Notes

https://listman.redhat.com/archives/libguestfs/2021-May/msg00013.html
https://github.com/libguestfs/hivex/commit/8f1935733b10d974a1a4176d38dd151ed98cf381

Search for package or bug name: Reporting problems