CVE-2021-3508

NameCVE-2021-3508
DescriptionA flaw was found in PDFResurrect in version 0.22b. There is an infinite loop in get_xref_linear_skipped() in pdf.c via a crafted PDF file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pdfresurrect (PTS)stretch0.12-6vulnerable
stretch (security)0.12-6+deb9u1vulnerable
buster0.15-2vulnerable
bullseye, sid0.22-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pdfresurrectsource(unstable)(unfixed)unimportant

Notes

https://github.com/enferex/pdfresurrect/issues/17
https://github.com/enferex/pdfresurrect/commit/7e35d1806e111fd28610ccc86bb33f54792ac370
Hang in CLI tool, no security impact

Search for package or bug name: Reporting problems