CVE-2021-3516

NameCVE-2021-3516
DescriptionThere's a flaw in libxml2's xmllint in versions before 2.9.11. An attacker who is able to submit a crafted file to be processed by xmllint could trigger a use-after-free. The greatest impact of this flaw is to confidentiality, integrity, and availability.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2653-1
NVD severitymedium
Debian Bugs987739

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libxml2 (PTS)stretch2.9.4+dfsg1-2.2+deb9u2vulnerable
stretch (security)2.9.4+dfsg1-2.2+deb9u5fixed
buster2.9.4+dfsg1-7+deb10u2fixed
bullseye2.9.10+dfsg-6.7fixed
bookworm, sid2.9.12+dfsg-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libxml2sourcestretch2.9.4+dfsg1-2.2+deb9u4DLA-2653-1
libxml2sourcebuster2.9.4+dfsg1-7+deb10u2
libxml2source(unstable)2.9.10+dfsg-6.6987739

Notes

https://gitlab.gnome.org/GNOME/libxml2/-/issues/230
https://gitlab.gnome.org/GNOME/libxml2/-/commit/1358d157d0bd83be1dfe356a69213df9fac0b539

Search for package or bug name: Reporting problems