CVE-2021-35197

NameCVE-2021-35197
DescriptionIn MediaWiki before 1.31.15, 1.32.x through 1.35.x before 1.35.3, and 1.36.x before 1.36.1, bots have certain unintended API access. When a bot account has a "sitewide block" applied, it is able to still "purge" pages through the MediaWiki Action API (which a "sitewide block" should have prevented).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2779-1, DSA-4979-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
mediawiki (PTS)stretch1:1.27.7-1~deb9u3vulnerable
stretch (security)1:1.27.7-1~deb9u10fixed
buster, buster (security)1:1.31.16-1~deb10u1fixed
bullseye (security), bullseye1:1.35.4-1~deb11u1fixed
bookworm, sid1:1.35.4-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
mediawikisourcestretch1:1.27.7-1~deb9u10DLA-2779-1
mediawikisourcebuster1:1.31.16-1~deb10u1DSA-4979-1
mediawikisourcebullseye1:1.35.4-1~deb11u1DSA-4979-1
mediawikisource(unstable)1:1.35.3-1

Notes

https://lists.wikimedia.org/hyperkitty/list/wikitech-l@lists.wikimedia.org/thread/YR3X4L2CPSEJVSY543AWEO65TD6APXHP/
https://phabricator.wikimedia.org/T280226

Search for package or bug name: Reporting problems