CVE-2021-3533

NameCVE-2021-3533
DescriptionA flaw was found in Ansible if an ansible user sets ANSIBLE_ASYNC_DIR to a subdirectory of a world writable directory. When this occurs, there is a race condition on the managed machine. A malicious, non-privileged account on the remote machine can exploit the race condition to access the async result data. This flaw affects Ansible Tower 3.7 and Ansible Automation Platform 1.2.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitylow

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ansible (PTS)stretch2.2.1.0-2+deb9u1vulnerable
stretch (security)2.2.1.0-2+deb9u2vulnerable
buster2.7.7+dfsg-1vulnerable
buster (security)2.7.7+dfsg-1+deb10u1vulnerable
bookworm, sid, bullseye2.10.7+merged+base+2.10.8+dfsg-1vulnerable
ansible-base (PTS)bookworm, sid2.10.5+dfsg-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ansiblesource(unstable)(unfixed)
ansible-basesource(unstable)(unfixed)

Notes

[bullseye] - ansible <postponed> (Minor issue, revisit when/if fixed upstream)
[buster] - ansible <postponed> (Minor issue, revisit when/if fixed upstream)
https://bugzilla.redhat.com/show_bug.cgi?id=1956477

Search for package or bug name: Reporting problems