CVE-2021-3546

NameCVE-2021-3546
DescriptionA flaw was found in vhost-user-gpu of QEMU in versions up to and including 6.0. An out-of-bounds write vulnerability can allow a malicious guest to crash the QEMU process on the host resulting in a denial of service or potentially execute arbitrary code on the host with the privileges of the QEMU process. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs989042

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qemu (PTS)stretch1:2.8+dfsg-6+deb9u9vulnerable
stretch (security)1:2.8+dfsg-6+deb9u14vulnerable
buster, buster (security)1:3.1+dfsg-8+deb10u8vulnerable
bullseye, sid1:5.2+dfsg-10vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qemusource(unstable)(unfixed)989042

Notes

[bullseye] - qemu <no-dsa> (Minor issue)
[buster] - qemu <no-dsa> (Minor issue)
[stretch] - qemu <postponed> (Minor issue; can be fixed in next update)
https://bugzilla.redhat.com/show_bug.cgi?id=1958978
https://lists.nongnu.org/archive/html/qemu-devel/2021-05/msg01155.html
https://lists.nongnu.org/archive/html/qemu-devel/2021-05/msg01154.html
https://gitlab.com/qemu-project/qemu/-/commit/9f22893a

Search for package or bug name: Reporting problems