CVE-2021-35513

NameCVE-2021-35513
DescriptionMermaid before 8.11.0 allows XSS when the antiscript feature is used.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs990449

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
node-mermaid (PTS)bullseye, sid8.7.0+ds+~cs27.17.17-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
node-mermaidsource(unstable)8.7.0+ds+~cs27.17.17-3990449

Notes

https://github.com/mermaid-js/mermaid/issues/2122
https://github.com/mermaid-js/mermaid/pull/2123

Search for package or bug name: Reporting problems