CVE-2021-3560

NameCVE-2021-3560
DescriptionIt was found that polkit could be tricked into bypassing the credential checks for D-Bus requests, elevating the privileges of the requestor to the root user. This flaw could be used by an unprivileged local attacker to, for example, create a new local administrator. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)
Debian Bugs989429

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
policykit-1 (PTS)buster, buster (security)0.105-25+deb10u1fixed
bullseye (security), bullseye0.105-31+deb11u1fixed
bookworm122-3fixed
sid, trixie124-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
policykit-1sourcestretch(not affected)
policykit-1sourcebuster(not affected)
policykit-1source(unstable)0.105-31989429

Notes

[buster] - policykit-1 <not-affected> (Vulnerable code introduced later)
[stretch] - policykit-1 <not-affected> (Vulnerable code introduced later)
Issue Upstream introduced in 0.113 with https://gitlab.freedesktop.org/polkit/polkit/-/commit/bfa5036bfb93582c5a87c44b847957479d911e38
Debian backported 0.113 commits in 0.105-26
Fixed by: https://gitlab.freedesktop.org/polkit/polkit/-/commit/a04d13affe0fa53ff618e07aa8f57f4c0e3b9b81 (0.119)
https://gitlab.freedesktop.org/polkit/polkit/-/issues/140
https://bugzilla.redhat.com/show_bug.cgi?id=1961710
https://www.openwall.com/lists/oss-security/2021/06/03/1
https://github.blog/2021-06-10-privilege-escalation-polkit-root-on-linux-with-bug/

Search for package or bug name: Reporting problems