CVE-2021-3572

NameCVE-2021-3572
DescriptionA flaw was found in python-pip in the way it handled Unicode separators in git references. A remote attacker could possibly use this issue to install a different revision on a repository. The highest threat from this vulnerability is to data integrity. This is fixed in python-pip version 21.1.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
python-pip (PTS)buster18.1-5vulnerable
bullseye20.3.4-4+deb11u1fixed
bookworm, sid22.1.1+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
python-pipsource(unstable)20.3.4-2

Notes

[buster] - python-pip <no-dsa> (Minor issue)
[stretch] - python-pip <postponed> (Minor issue. Fix along with next DLA)
https://bugs.launchpad.net/ubuntu/+source/python-pip/+bug/1926957
https://github.com/pypa/pip/pull/9827
https://github.com/pypa/pip/commit/ca832b2836e0bffa7cf95589acdcd71230f5834e (21.1)

Search for package or bug name: Reporting problems