CVE-2021-35939

NameCVE-2021-35939
DescriptionIt was found that the fix for CVE-2017-7500 and CVE-2017-7501 was incomplete: the check was only implemented for the parent directory of the file to be created. A local unprivileged user who owns another ancestor directory could potentially use this flaw to gain root privileges. The highest threat from this vulnerability is to data confidentiality and integrity as well as system availability.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs990543

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
rpm (PTS)buster4.14.2.1+dfsg1-1vulnerable
bullseye4.16.1.2+dfsg1-3vulnerable
bookworm, sid4.17.1.1+dfsg-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
rpmsource(unstable)(unfixed)990543

Notes

[bullseye] - rpm <ignored> (Minor issue)
[buster] - rpm <ignored> (Minor issue)
[stretch] - rpm <no-dsa> (Minor issue)
https://bugzilla.redhat.com/show_bug.cgi?id=1964129

Search for package or bug name: Reporting problems