CVE-2021-36045

NameCVE-2021-36045
DescriptionXMP Toolkit SDK versions 2020.1 (and earlier) are affected by an out-of-bounds read vulnerability that could lead to disclosure of arbitrary memory. An attacker could leverage this vulnerability to bypass mitigations such as ASLR. Exploitation of this issue requires user interaction in that a victim must open a malicious file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
exempi (PTS)buster2.5.0-2vulnerable
bullseye2.5.2-1vulnerable
bookworm2.6.1-2fixed
sid2.6.2-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
exempisource(unstable)2.6.0-1

Notes

[bullseye] - exempi <no-dsa> (Minor issue)
[buster] - exempi <no-dsa> (Minor issue)
https://helpx.adobe.com/security/products/xmpcore/apsb21-65.html
https://cgit.freedesktop.org/exempi/commit/?h=2.6.0&id=77a3fe7096f8ebf301e2bfe1e6dc023b4ff6dc48
https://gitlab.freedesktop.org/libopenraw/exempi/-/releases

Search for package or bug name: Reporting problems