CVE-2021-36050

NameCVE-2021-36050
DescriptionXMP Toolkit SDK version 2020.1 (and earlier) is affected by a buffer overflow vulnerability potentially resulting in arbitrary code execution in the context of the current user. Exploitation requires user interaction in that a victim must open a crafted file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
exempi (PTS)stretch2.4.1-1vulnerable
buster2.5.0-2vulnerable
bookworm, bullseye2.5.2-1vulnerable
sid2.6.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
exempisource(unstable)2.6.0-1

Notes

https://helpx.adobe.com/security/products/xmpcore/apsb21-65.html
https://cgit.freedesktop.org/exempi/commit/?h=2.6.0&id=77a3fe7096f8ebf301e2bfe1e6dc023b4ff6dc48
https://gitlab.freedesktop.org/libopenraw/exempi/-/releases
check for fixing commit

Search for package or bug name: Reporting problems