CVE-2021-3606

NameCVE-2021-3606
DescriptionOpenVPN before version 2.5.3 on Windows allows local users to load arbitrary dynamic loadable libraries via an OpenSSL configuration file if present, which allows the user to run arbitrary code with the same privilege level as the main OpenVPN process (openvpn.exe).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openvpn (PTS)stretch2.4.0-6+deb9u3fixed
stretch (security)2.4.0-6+deb9u1fixed
buster2.4.7-1+deb10u1fixed
bookworm, bullseye, sid2.5.1-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openvpnsource(unstable)(not affected)

Notes

- openvpn <not-affected> (Windows-specific)

Search for package or bug name: Reporting problems