CVE-2021-36082

NameCVE-2021-36082
Descriptionntop nDPI 3.4 has a stack-based buffer overflow in processClientServerHello.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs990528

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ndpi (PTS)stretch1.8-1fixed
stretch (security)1.8-1+deb9u1fixed
buster2.6-3fixed
bullseye, sid3.4-3vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ndpisourcestretch(not affected)
ndpisourcebuster(not affected)
ndpisource(unstable)(unfixed)990528

Notes

[buster] - ndpi <not-affected> (Vulnerable code not present)
[stretch] - ndpi <not-affected> (Vulnerable code added later)
https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=30393
https://github.com/google/oss-fuzz-vulns/blob/main/vulns/ndpi/OSV-2021-304.yaml
https://github.com/ntop/nDPI/commit/1ec621c85b9411cc611652fd57a892cfef478af3

Search for package or bug name: Reporting problems