CVE-2021-36083

NameCVE-2021-36083
DescriptionKDE KImageFormats 5.70.0 through 5.81.0 has a stack-based buffer overflow in XCFImageFormat::loadTileRLE.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs990527

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
kimageformats (PTS)stretch5.28.0-1vulnerable
buster5.54.0-1vulnerable
bullseye5.78.0-5fixed
bookworm, sid5.86.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
kimageformatssourceexperimental5.83.0-1
kimageformatssource(unstable)5.78.0-5990527

Notes

[buster] - kimageformats <no-dsa> (Minor issue)
[stretch] - kimageformats <no-dsa> (Minor issue)
https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=33742
https://github.com/google/oss-fuzz-vulns/blob/main/vulns/kimageformats/OSV-2021-695.yaml
https://invent.kde.org/frameworks/kimageformats/commit/297ed9a2fe339bfe36916b9fce628c3242e5be0f

Search for package or bug name: Reporting problems