CVE-2021-36089

NameCVE-2021-36089
DescriptionGrok 7.6.6 through 9.2.0 has a heap-based buffer overflow in grk::FileFormatDecompress::apply_palette_clr (called from grk::FileFormatDecompress::applyColour).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs990525

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libgrokj2k (PTS)bullseye, sid7.6.6-3vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libgrokj2ksource(unstable)(unfixed)990525

Notes

https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=33544
https://github.com/google/oss-fuzz-vulns/blob/main/vulns/grok/OSV-2021-677.yaml

Search for package or bug name: Reporting problems