CVE-2021-3612

NameCVE-2021-3612
DescriptionAn out-of-bounds memory write flaw was found in the Linux kernel's joystick devices subsystem in versions before 5.9-rc1, in the way the user calls ioctl JSIOCSBTNMAP. This flaw allows a local user to crash the system or possibly escalate their privileges on the system. The highest threat from this vulnerability is to confidentiality, integrity, as well as system availability.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2785-1
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)stretch4.9.228-1vulnerable
stretch (security)4.9.272-2vulnerable
buster4.19.208-1fixed
buster (security)4.19.194-3vulnerable
bullseye5.10.70-1fixed
bullseye (security)5.10.46-5fixed
bookworm5.14.9-2fixed
sid5.14.12-1fixed
linux-4.19 (PTS)stretch (security)4.19.208-1~deb9u1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsourcebuster4.19.208-1
linuxsource(unstable)5.10.46-3
linux-4.19sourcestretch4.19.208-1~deb9u1DLA-2785-1

Notes

Introduced by: https://lore.kernel.org/linux-input/20210219083215.GS2087@kadam/

Search for package or bug name: Reporting problems