CVE-2021-36133

NameCVE-2021-36133
DescriptionThe OPTEE-OS CSU driver for NXP i.MX SoC devices lacks security access configuration for several models, resulting in TrustZone bypass because the NonSecure World can perform arbitrary memory read/write operations on Secure World memory. This involves a DMA capable peripheral.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
optee-os (PTS)sid, trixie4.2.0-3vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
optee-ossource(unstable)(unfixed)unimportant

Notes

https://github.com/OP-TEE/optee_os/security/advisories/GHSA-6q85-3ph3-rm47
Upstream does not share F-Secure's view (the reporters) on the severity and
does not consider this to be a security issue.

Search for package or bug name: Reporting problems