CVE-2021-36158

NameCVE-2021-36158
DescriptionIn the xrdp package (in branches through 3.14) for Alpine Linux, RDP sessions are vulnerable to man-in-the-middle attacks because pre-generated RSA certificates and private keys are used.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xrdp (PTS)buster, buster (security)0.9.9-1+deb10u1fixed
bullseye0.9.12-1.1fixed
bookworm, sid0.9.21.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xrdpsource(unstable)(not affected)

Notes

- xrdp <not-affected> (xrdp as packaged in Alpine)

Search for package or bug name: Reporting problems