CVE-2021-3624

NameCVE-2021-3624
DescriptionThere is an integer overflow vulnerability in dcraw. When the victim runs dcraw with a maliciously crafted X3F input image, arbitrary code may be executed in the victim's system.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
Debian Bugs984761

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
dcraw (PTS)buster, bullseye9.28-2vulnerable
bookworm, sid9.28-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
dcrawsource(unstable)9.28-3984761

Notes

[bullseye] - dcraw <no-dsa> (Minor issue)
[buster] - dcraw <no-dsa> (Minor issue)
[stretch] - dcraw <no-dsa> (Minor issue)

Search for package or bug name: Reporting problems