CVE-2021-3630

NameCVE-2021-3630
DescriptionAn out-of-bounds write vulnerability was found in DjVuLibre in DJVU::DjVuTXT::decode() in DjVuText.cpp via a crafted djvu file which may lead to crash and segmentation fault. This flaw affects DjVuLibre versions prior to 3.5.28.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-2702-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
djvulibre (PTS)stretch3.5.27.1-7vulnerable
stretch (security)3.5.27.1-7+deb9u2fixed
buster3.5.27.1-10vulnerable
bookworm, sid, bullseye3.5.28-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
djvulibresourcestretch3.5.27.1-7+deb9u2DLA-2702-1
djvulibresource(unstable)3.5.27.1-12

Notes

https://sourceforge.net/p/djvu/bugs/302/
https://sourceforge.net/p/djvu/djvulibre-git/ci/7b0ef20690e08f1fe124aebbf42f6310e2f40f81/

Search for package or bug name: Reporting problems