CVE-2021-36367

NameCVE-2021-36367
DescriptionPuTTY through 0.75 proceeds with establishing an SSH session even if it has never sent a substantive authentication response. This makes it easier for an attacker-controlled SSH server to present a later spoofed authentication prompt (that the attacker can use to capture credential data, and use that data for purposes that are undesired by the client user).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs990901

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
putty (PTS)stretch (security), stretch0.67-3+deb9u1vulnerable
buster0.70-6vulnerable
bullseye0.74-1vulnerable
bookworm, sid0.76-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
puttysource(unstable)0.75-3990901

Notes

[bullseye] - putty <no-dsa> (Minor issue)
[buster] - putty <no-dsa> (Minor issue)
[stretch] - putty <no-dsa> (Minor issue)
https://git.tartarus.org/?p=simon/putty.git;a=commit;h=1dc5659aa62848f0aeb5de7bd3839fecc7debefa

Search for package or bug name: Reporting problems