CVE-2021-3643

NameCVE-2021-3643
DescriptionA flaw was found in sox 14.4.1. The lsx_adpcm_init function within libsox leads to a global-buffer-overflow. This flaw allows an attacker to input a malicious file, leading to the disclosure of sensitive information.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs1010374

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
sox (PTS)stretch14.4.1-5+deb9u2vulnerable
buster14.4.2+git20190427-1vulnerable
bullseye14.4.2+git20190427-2vulnerable
bookworm, sid14.4.2+git20190427-3vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
soxsource(unstable)(unfixed)1010374

Notes

https://bugzilla.redhat.com/show_bug.cgi?id=1980626
Triggered by same reproducer as for CVE-2021-23210
https://sourceforge.net/p/sox/bugs/351/

Search for package or bug name: Reporting problems