CVE-2021-3664

NameCVE-2021-3664
Descriptionurl-parse is vulnerable to URL Redirection to Untrusted Site
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs991577

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
node-url-parse (PTS)stretch1.0.5-2+deb9u1vulnerable
buster1.2.0-2+deb10u1vulnerable
bookworm, sid, bullseye1.5.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
node-url-parsesourcestretch(unfixed)end-of-life
node-url-parsesource(unstable)1.5.3-1991577

Notes

[buster] - node-url-parse <no-dsa> (Minor issue)
[stretch] - node-url-parse <end-of-life> (Nodejs in stretch not covered by security support)
https://huntr.dev/bounties/1625557993985-unshiftio/url-parse/
https://github.com/unshiftio/url-parse/commit/81ab967889b08112d3356e451bf03e6aa0cbb7e0

Search for package or bug name: Reporting problems