CVE-2021-36691

NameCVE-2021-36691
Descriptionlibjxl v0.5.0 is affected by a Assertion failed issue in lib/jxl/image.cc jxl::PlaneBase::PlaneBase(). When encoding a malicous GIF file using cjxl, an attacker can trigger a denial of service.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
jpeg-xlunknown(unstable)(unfixed)

Notes

https://github.com/libjxl/libjxl/issues/422
Special case of https://github.com/libjxl/libjxl/issues/762

Search for package or bug name: Reporting problems