CVE-2021-36754

NameCVE-2021-36754
DescriptionPowerDNS Authoritative Server 4.5.0 before 4.5.1 allows anybody to crash the process by sending a specific query (QTYPE 65535) that causes an out-of-bounds exception.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pdns (PTS)buster4.1.6-3+deb10u1fixed
bullseye4.4.1-1fixed
bookworm, sid4.6.3-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pdnssource(unstable)(not affected)

Notes

- pdns <not-affected> (Vulnerable code introduced in 4.5.0)
https://www.openwall.com/lists/oss-security/2021/07/26/2

Search for package or bug name: Reporting problems