CVE-2021-36773

NameCVE-2021-36773
DescriptionuBlock Origin before 1.36.2 and nMatrix before 4.4.9 support an arbitrary depth of parameter nesting for strict blocking, which allows crafted web sites to cause a denial of service (unbounded recursion that can trigger memory consumption and a loss of all blocking functionality).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs991344, 991386

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ublock-origin (PTS)stretch1.22.2+dfsg-1~deb9u1vulnerable
buster1.30.0+dfsg-1~deb10u1vulnerable
bullseye1.33.0+dfsg-1vulnerable
bookworm, sid1.37.0+dfsg-1fixed
umatrix (PTS)buster1.3.16+dfsg-2vulnerable
sid1.4.0+dfsg-1vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ublock-originsource(unstable)1.37.0+dfsg-1991386
umatrixsource(unstable)(unfixed)991344

Notes

[bullseye] - ublock-origin <no-dsa> (Minor issue)
[buster] - ublock-origin <no-dsa> (Minor issue)
[stretch] - ublock-origin <no-dsa> (Minor issue)
[buster] - umatrix <no-dsa> (Minor issue)
https://github.com/vtriolet/writings/blob/main/posts/2021/ublock_origin_and_umatrix_denial_of_service.adoc

Search for package or bug name: Reporting problems