CVE-2021-3695

NameCVE-2021-3695
DescriptionA crafted 16-bit grayscale PNG image may lead to a out-of-bounds write in the heap area. An attacker may take advantage of that to cause heap data corruption or eventually arbitrary code execution and circumvent secure boot protections. This issue has a high complexity to be exploited as an attacker needs to perform some triage over the heap layout to achieve signifcant results, also the values written into the memory are repeated three times in a row making difficult to produce valid payloads. This flaw affects grub2 versions prior grub-2.12.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
grub2 (PTS)buster2.06-3~deb10u1fixed
buster (security)2.06-3~deb10u2fixed
bullseye2.06-3~deb11u1fixed
bullseye (security)2.06-3~deb11u4fixed
bookworm2.06-5fixed
sid2.06-6fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
grub2sourcebuster2.06-3~deb10u1
grub2sourcebullseye2.06-3~deb11u1
grub2source(unstable)2.06-3

Notes

[stretch] - grub2 <ignored> (No SecureBoot support in stretch)
[jessie] - grub2 <ignored> (No SecureBoot support in jessie)
https://www.openwall.com/lists/oss-security/2022/06/07/5

Search for package or bug name: Reporting problems