CVE-2021-36976

NameCVE-2021-36976
Descriptionlibarchive 3.4.1 through 3.5.1 has a use-after-free in copy_string (called from do_uncompress_block and process_block).
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium
Debian Bugs991442

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libarchive (PTS)stretch (security), stretch3.2.2-2+deb9u2fixed
buster, buster (security)3.3.3-4+deb10u1vulnerable
bookworm, sid, bullseye3.4.3-2vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libarchivesourcestretch(not affected)
libarchivesource(unstable)(unfixed)991442

Notes

[bullseye] - libarchive <no-dsa> (Minor issue)
[buster] - libarchive <no-dsa> (Minor issue)
[stretch] - libarchive <not-affected> (Vulnerable code introduced by 47bb818 in version 3.4.1)
https://github.com/libarchive/libarchive/issues/1554
https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=32375
https://github.com/google/oss-fuzz-vulns/blob/main/vulns/libarchive/OSV-2021-557.yaml

Search for package or bug name: Reporting problems